So-net無料ブログ作成
エステ

ubuntu のアップグレードを行う [Linux コマンド・設定 Memo]

5月5日に ubuntu 10.04 がリリースされましたので、
今まで使っている 9.10 からアップグレードします。

といっても、コマンド一つ です。


# do-release-upgrade

あとは、ひたすら、y で終わりです。。

(以下レスポンスの一部)
Checking for a new ubuntu release
Done Upgrade tool signature
Done Upgrade tool
Done downloading            
extracting 'lucid.tar.gz'
authenticate 'lucid.tar.gz' against 'lucid.tar.gz.gpg' 
tar: Removing leading `/' from member names

Reading cache

Checking package manager

Continue running under SSH? 

This session appears to be running under ssh. It is not recommended 
to perform a upgrade over ssh currently because in case of failure it 
is harder to recover. 

If you continue, an additional ssh daemon will be started at port 
'9004'. 
Do you want to continue? 

Continue [yN] y

Starting additional sshd 

To make recovery in case of failure easier, an additional sshd will 
be started on port '9004'. If anything goes wrong with the running 
ssh you can still connect to the additional one. 


Reading package lists: Done
Reading state information: Done
Reading state information: Done
Reading state information: Done
Done downloading            
Reading package lists: Done
Reading state information: Done
Reading state information: Done
Reading state information: Done

Updating repository information
WARNING: Failed to read mirror file
Done downloading            

Checking package manager
Reading package lists: Donelucid-security/multiverse Packages: 98   
Reading state information: Done
Reading state information: Done
Reading state information: Done

Calculating the changes

Calculating the changes

Support for some applications ended 

Canonical Ltd. no longer provides support for the following software 
packages. You can still get support from the community. 

Demoted: 
libcompress-bzip2-perl, netcat-traditional 



Do you want to start the upgrade? 


3 packages are going to be removed. 47 new packages are going to be 
installed. 373 packages are going to be upgraded. 

You have to download a total of 233M. This download will take about 2 
minutes with your connection. 

Fetching and installing the upgrade can take several hours. Once the 
download has finished, the process cannot be cancelled. 

 Continue [yN]  Details [d]y

途中、grubのインストール先を聞かれます。

 ┌─────────┤ Configuring grub-pc ├──────────┐  
 
The grub-pc package is being upgraded.  
This menu allows you to select which devices you'd 
like grub-install to be automatically run for, if any. 

It is recommended that you do this in most situations, 
to prevent the installed GRUB from getting out of sync 
with other components such as grub.cfg or with newer 
Linux images it  will have to load. 

 If you're unsure which drive is designated as boot 
drive by your BIOS, it is often a good idea to install 
GRUB to all of them.

Note: It is possible to install GRUB to partition boot 
records as well. However, this forces GRUB to use the
 blocklist mechanism, which makes it less reliable, 
and therefore is not recommended.  

GRUB install devices:   

    [ ] /dev/sda (2000398 MB, Hitachi_HDS722020ALA330)   
    [ ] - /dev/sda1 (2000398 MB)  
    [ ] /dev/sdb (2000398 MB, Hitachi_HDS722020ALA330)  
    [ ] - /dev/sdb1 (2000398 MB)   
    [ ] /dev/sdc (2000398 MB, Hitachi_HDS722020ALA330)  
    [ ] - /dev/sdc1 (2000398 MB)   
    [ ] /dev/sdd (2000398 MB, Hitachi_HDS722020ALA330)  
    [ ] - /dev/sdd1 (2000398 MB)   
    [*] /dev/sde (8166 MB, USB_Reader)  
    [ ] - /dev/sde1 (7800 MB)   
    [ ] - /dev/sde2 (366 MB)  
 
 
                                            <Ok>   
───────────────────────────────────────────


再起動して、完了です[ぴかぴか(新しい)]

これで、zabbixが1.6.4から1.8.1へ
その他もろもろアップデートされました〜


nice!(0)  コメント(0)  トラックバック(0) 
共通テーマ:パソコン・インターネット

nice! 0

コメント 0

コメントを書く

お名前:
URL:
コメント:
画像認証:
下の画像に表示されている文字を入力してください。

トラックバック 0

この広告は前回の更新から一定期間経過したブログに表示されています。更新すると自動で解除されます。

×

この広告は1年以上新しい記事の更新がないブログに表示されております。